ClassNotFound qv – Updated

I think many of you may have come across the following problem when running “install.cmd” in your forge folder:

RetroGuard error: COM.rl.obf.classfile.ClassFileException: ClassNotFound qv

I have a couple of steps to try and fix this issue:

  • Try running “cleanup.bat” inside your forge/mcp/ folder. Then try “decompile.bat” inside the same folder.
  • Try running “startclient.bat” inside of force/mcp/. If this starts Minecraft, try the recipe that is added by the BaseMod (dirt -> dirt). (Make sure you’ve gotten the BaseMod downloaded.) If the BaseMod recipe works, you’re good!

If those don’t work, try looking at the log files in forge/mcp/logs/ folder. Specifically look at “client_compile.log”, “mcperr.log”, and “mcp.log”. If someone can past their logs in a comment here (or better yet on pastebin.com with a link in the comments here) I can take a further look and hopefully get everybody on the same page.

Updated: I started up a virtual machine with Windows on it and was able to reproduce this error myself. I am not sure what it means but I don’t believe it will be a problem for us. We should still be able to load and run our mods.

I created the following screencast to guide you through the entire process of getting the base of your environment set up:

2 thoughts on “ClassNotFound qv – Updated

  1. Michael Combs

    == MCP 7.44 (data: 7.44, client: 1.5.1, server: 1.5.1) ==
    # found ff, ff patches, srgs, name csvs, doc csvs, param csvs, renumber csv, ast
    yle, astyle config
    > Creating Retroguard config files
    !! Modified jar detected. Unpredictable results !!
    == Decompiling client using fernflower ==
    > Creating SRGs
    > Applying Retroguard
    > Applying MCInjector
    > Unpacking jar
    > Copying classes
    > Decompiling
    > Copying sources
    > Applying fernflower fixes
    > Applying patches
    > Cleaning comments
    – Done in 120.01 seconds
    == Reformating client ==
    > Cleaning sources
    > Replacing OpenGL constants
    > Reformating sources
    – Done in 11.22 seconds
    == Updating client ==
    > Adding javadoc
    > Renaming sources
    – Done in 11.72 seconds
    !! Modified jar detected. Unpredictable results !!
    == Decompiling server using fernflower ==
    > Creating SRGs
    > Applying Retroguard
    ‘”C:\Program Files\Java\jdk1.7.0_21\bin\java” -cp “runtime\bin\retroguard.jar;li
    b;lib\*;jars\minecraf…’ failed : 1

    == ERRORS FOUND ==

    Unrecoverable error during obfuscation, see log file for details.
    RetroGuard error: COM.rl.obf.classfile.ClassFileException: ClassNotFound qv
    ==================

    Decompile failed
    Press any key to continue . . .

    1. Elliott Post author

      Is this the output of running decompile.bat? Can you post your forge/mcp/logs/mcperr.log?

Comments are closed.